History | Log In     View a printable version of the current page.  
Issue Details (XML | Word | Printable)

Key: OX-1562
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: andrew.hill
Reporter: Gabe Harriman
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
OpenX Ad Server

mod_geoip doesn't work with lighttpd

Created: 12/Mar/08 01:07 PM   Updated: 19/Sep/08 04:24 AM
Component/s: OXP: Delivery Engine
Affects Version/s: OpenX 2.4.4
Fix Version/s: OpenX 2.5.67-beta, OXP 2.7.5-dev, OpenX 2.4.6, Milestone 19
Security Level: Public (All users can see these issues)

Time Tracking:
Original Estimate: Not Specified
Remaining Estimate: 0h
Time Spent - 0.38h
Time Spent: 0.38h
Time Spent - 0.38h

Environment: PHP 5.2.5


 Description  « Hide
The majority of the mod_geoip $_SERVER variable names are slightly different with mod_geoip in lighttpd compared to the apache version. here is a (partial) print_r of my $_SERVER:

Array
(
[SERVER_SOFTWARE] => lighttpd/1.4.18
[GEOIP_COUNTRY_CODE] => US
[GEOIP_COUNTRY_CODE3] => USA
[GEOIP_COUNTRY_NAME] => United States
[GEOIP_CITY_REGION] => VA
[GEOIP_CITY_NAME] => Aldie
[GEOIP_CITY_POSTAL_CODE] => 20105
[GEOIP_CITY_LATITUDE] => 38.963600
[GEOIP_CITY_LONG_LATITUDE] => -77.613098
[GEOIP_CITY_DMA_CODE] => 511
[GEOIP_CITY_AREA_CODE] => 703
)



 All   Comments   Work Log   Change History   FishEye   Crucible   Builds      Sort Order: Ascending order - Click to sort in descending order
There are no comments yet on this issue.