History | Log In     View a printable version of the current page.  
Issue Details (XML | Word | Printable)

Key: OX-2838
Type: Sub-task Sub-task
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Chris Nutting
Reporter: Chris Nutting
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
OpenX Ad Server
OX-2210

Move existing upgrade methods out of the plugins and into a separate (pre-plugin) upgrade class

Created: 12/May/08 12:42 PM   Updated: 15/May/08 03:22 PM
Component/s: OXP: Plugins
Affects Version/s: None
Fix Version/s: OXP 2.7.5-dev, Milestone 19
Security Level: Public (All users can see these issues)

Time Tracking:
Original Estimate: Not Specified
Remaining Estimate: 0h
Time Spent - 4h
Time Spent: 4h
Time Spent - 4h


 Description  « Hide
Unit.Upgrade Migration Classes.migration_tables_core_128
Investigations show that these plugins contain their own upgrade methods, getUpgradeFromEarly() is called by 2.0 and 2.3 migration classes and it calls a variety of built-in upgrade methods that vary from plugin to plugin, eg:
getDeliveryLimitationPluginUpgradeThreeThirtyOneAlpha()
getDeliveryLimitationPluginDowngradeThreeTwentyNineAlpha()
OA_limitationsGetAUpgradeFor20Regexp()
OA_limitationsGetUpgradeForContains()
OA_limitationsGetUpgradeForGeoNetspeed()
OA_limitationsGetUpgradeForGeoRegion()
OA_limitationsGetUpgradeForGeoCity()
These methods should be looked at to see if they can be removed from the plugin. Apparently they are also compiled into the delivery engine.

 All   Comments   Work Log   Change History   FishEye   Crucible   Builds      Sort Order: Ascending order - Click to sort in descending order
Error communicating with FishEye: java.io.IOException: https://developer.openx.org/fisheye/api/rest/query returned 503 Service Temporarily Unavailable