History | Log In     View a printable version of the current page.  
Issue Details (XML | Word | Printable)

Key: OX-3535
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Major Major
Assignee: Lukasz Wikierski
Reporter: Pawel Dachterski
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
OpenX Ad Server

Emails logging isn't working

Created: 08/Jul/08 12:16 PM   Updated: 12/Aug/08 09:15 AM
Component/s: OXP: Email System
Affects Version/s: OpenX 2.4.7, OpenX 2.5.70-beta
Fix Version/s: OpenX 2.4.8, Milestone 21, OpenX 2.6.1, OpenX 2.7.10-dev
Security Level: Public (All users can see these issues)

Time Tracking:
Original Estimate: Not Specified
Remaining Estimate: 0h
Time Spent - 11.42h
Time Spent: 11.42h
Time Spent - 11.42h


 Description  « Hide
Emails logging isn't working.

In UI is settings "Email log: Log all outgoing email messages", but it has no effect.

In code this settings is used only in lib-warnings.inc.php, however this file contains only one function which is never called in code. Also lib-warnings.inc.php is never included in code.

Actions:
1. Depends on Product decision: - logging emails is lack of functionality or log emails setting should be removed from code
2. Review and remove unused lib-warnings.inc.php from code base.



 All   Comments   Work Log   Change History   FishEye   Crucible   Builds      Sort Order: Ascending order - Click to sort in descending order
Lukasz Wikierski - 16/Jul/08 10:41 AM
Fixed:
  • now warnings (impending expiry), activation, deactivation and delivery (advertiser) email raports are logged to maintenance log
  • as result new action "Activation Mailed" was added
  • added unit tests to check if emails are logged


Pawel Dachterski - 16/Jul/08 02:15 PM
"Log all outgoing email messages" switch isn't working in 2.4.8-rc3
because of:
if ($GLOBALS['_MAX']['PREF']['userlog_email'] = 't') {

should be

if ($GLOBALS['_MAX']['PREF']['userlog_email'] == 't') {

also would be good to ensure that ['PREF']['userlog_email'] is from Administrator preferences (e.g. not from Agency).


Lukasz Wikierski - 17/Jul/08 07:30 AM
Fixed, addational unit tests written (for 2.4 and 2.6),
+ small fix added: now actions 'mail sent' are always logged as user Maintenace.

Pawel Dachterski - 17/Jul/08 01:33 PM
works good in 2.4.8-rc5