History | Log In     View a printable version of the current page.  
Issue Details (XML | Word | Printable)

Key: OX-5027
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Critical Critical
Assignee: Miguel Correa
Reporter: Lukasz Wikierski
Votes: 0
Watchers: 1
Operations

If you were logged in you would be able to see more operations.
OpenX Ad Server

Bundled plugins are not auto-upgraded during openX upgrade

Created: 02/Mar/09 11:17 AM   Updated: 20/Mar/09 02:33 AM
Component/s: OXP: Installation & Upgrade System, OXP: Plugins
Affects Version/s: OpenX 2.7.30-beta
Fix Version/s: OpenX 2.7.30-beta, Milestone 29
Security Level: Public (All users can see these issues)

Time Tracking:
Original Estimate: Not Specified
Remaining Estimate: 0h
Time Spent - 18.83h
Time Spent: 18.83h
Time Spent - 18.83h

Environment: Windows XP, Apache 2.0, PHP Version 5.2.8
Issue Links:
Depends
 
Duplicate
 
Reference


 Description  « Hide
upgrading from 2.7.30-beta-rc6 to 2.7.30-beta-rc10.
openXDeliveryLog stay at version 0.1.2-dev, while in etc/plugins is version 1.0.3 available.

I've checked extensions/deliveryLog/oxLogConversion/logConversion.delivery.php to be sure that plugin wasn't upgraded.



 All   Comments   Work Log   Change History   FishEye   Crucible   Builds      Sort Order: Ascending order - Click to sort in descending order
Pawel Dachterski - 02/Mar/09 11:48 AM
After upgrade from 2.7.29-beta to 2.7.30-beta, plugins are still reported as old version ion Plugins page:
e.g. is openXMarket0.1.2-beta-rc5 - should be openXMarket0.1.3-beta-rc2

And confirmed case in description.


Miguel Correa - 04/Mar/09 02:00 PM
Bug fixed in Openx 2.7.30-beta-rc11

Chris Nutting - 07/Mar/09 02:26 AM
Looks good to me, merging down to //trunk now

Chris Nutting - 07/Mar/09 02:27 AM
Fixed in 2.7.30-beta-rc11

Miguel Correa - 09/Mar/09 10:19 AM
Reopened issue to handled with error messages.

Nataliya Drabyk - 10/Mar/09 02:28 PM - edited
During upgrade from openx-2.7.25-beta, openx-2.7.26 to 2.7.30-beta-rc11 plugin openXDeliveryLimitations 1.0.0 wasn't upgraded - Failed (Parse error, server returned invalid response)

Miguel Correa - 10/Mar/09 02:36 PM
This issue can't be tested until OX-5068 is fixed.



Miguel Correa - 10/Mar/09 05:14 PM
Issue reopened to avoid more comments and tests until OX-5068 as I said above.

Chris Nutting - 12/Mar/09 12:01 AM
This is resolved, I'm going to create a seperate ticket about the potential for a plugin to be downgraded by the installer (or via the UI)


Miguel Correa - 13/Mar/09 05:22 PM
Plugins are upgraded properly, it's true that the upgrade of openXDeliveryLimitations plugin is failing but it doesn't mean that Bundled plugins are not auto-upgraded. I've created OX-5098 to fix this bug.

Lukasz Dybcio - 18/Mar/09 12:41 PM
Working good in 2.7.30-beta-rc13, closing.